New Member, modified rapture, questions...

I’m a new member to the forum, currently based in Lincolnshire & in the process of joining the club.

I bought a 2008 1200 Sport (2v heads) a couple of weeks ago & have put in about 650 miles in the past week trying to acquaint myself with its joys & foibles; my daily ride for the past 22 years has been an 850 Norton Commando (I’m on the NOC & Access Norton sites), so this foray into 20th Century technology is a wild & entertaining ride, the bike is full of character & very, very red!, total rapture! She falls into right handers but need a little persuasion to fall left (flywheel or shaft? -I had an R90S in the 1980’s don’t remember so much movement - but of course now greater volume!). I’m gutted that the NOC Internationl Rally in Portugal has been cancelled, I was beginning to think that I’d take the Guzzi instead of the Commando.

Alas I have a problem (thus modified rapture) I was madly in love with the roseate goddess until this morning when she threw a hissy fit,flashed up the red warning light & ‘SERVICE’, when I pushed the starter everything went dead & remained so, failing to respond to the key - resolutely dark. Having arranged to meet friends I switched to the Commando (drained sump, topped up oil, topped up air in tyres, topped up fuel) & had a great blast down to Rutland Water & back.

When I returned, I noticed that the Guzzi’s warning light was flashing, in spirit of optimism I tried the key & got the ‘SERVICE’ message again, clocks then went dark & then displayed error code AP5(or S?)B 0016 which I believe is an Air Temperature sensor problem. A second try (ever the optimist) & the initialisation sequence completed successfully & with a prod on the button she burst into life!

I found the code to get into diagnostics on GuzziTech & found the following:
Zero ECU Codes
Dash Codes, nothing under A, but under M, I had the following:
DSB 001 Immobiliser fault Key code
DSB 002 key missing or transponder broken
DSB 007 oil sensor fault
DSB 008 oil pressure fault

Battery Voltage via dashboard : 11.4 volts (which is low, though my voltmeter reds 12.4 volts, still low,) - it had been 13.1v for the previous 2 weeks

I’m wondering if the battery has given up the ghost & low voltage is causing electrical errors, any advice would be gratefully received as my confidence in this glorious bike has taken a bit of a hit!

First step is(I think!) a new battery - any recommendations (or warnings?) for a replacement of the YUASA YTX20CH-BS - preferably AGM (I have a MotoBatt on the Commando & it’s excellent)

I tried to add a photo of the 2 ladies, but I’m guessing that is restricted because I’m not yet a full member, will do when possible!




Hi Mike, welcome to the forum. I know the guy who runs Access Norton he used to be my lodger!

The handling of guzzis has improved a lot since my first Guzzi (1974 850T) where the torque reaction meant you accellerated into right handers but shut down the throttle into left turns. The swinging arm geometry has developed so that should not be noticable any more but I guess most of us on here probably have just got used to it!

I am not sure about the warning code you have, but I am sure someone will be along soon with better knowledge than me. It could be a battery problem but it could also be corroded battery terminals or earth points. I would suggest that you clean all these up before you buy a new battery.

Best wishes

Hi Chris,

My it is a small world! Thank you for responding, i know what to do with the Commando, but this technological marvel is something else!

I’ve cleaned up the battery terminals, all now nice & shiny, this morning I contacted the dealership where I bought the bike, explained the events and they immediately offered to provide a new battery (so a shout out to M&S in Newcastle). The only problem is that I’m not going to get it for at lest 3 weeks due to the Covid-19 problem - I’ve just heard that the UK is going into a tighter lockdown, I know it’s a good idea I’m going to miss my rides tho’ at least I have a small garden to walk round.

I’ve cleared the codes & will charge & replace the battery, try & start her up & then check again for error codes, I noticed that the onboard diagnostics seem to measure 1 volt below my multimeter, we’ll see what happens.

Cheers, Mike

What type of battery is it? If it is lead/acid you could check and top up the levels (old school) and give it some charge. I would suspect that you may have already thought of that. Earth wires are always worth checking. ECUs are a mystery to me!

Below is a photo from 1983 Jerry (Norton Access) with his Commando he built in my front room, and the mono shock Guzzi Le Mans belonged to another friend called Batty (don’t ask)

And an earlier shot of my Triumph in the front room, with the tank and seat dummied on for the photo having a re-wire. You can just about see Jerry’s Commando in the background the engine is just visible behind the Triumph frame front tube. Both were stripped right down powder coated frames and in the photo just frames and engines on ply sheets on the floor. Great workshop the front room, wife No 1 had moved out, the workshop had carpet, heating and a kitchen next door, well it was the front room! I must have some better photos than this up in the loft but this is the only one I have scanned.

Hi Chris,

Interesting photo’s, love the donkey jacket! I used to ride my Suuzuki T10 wearing an Afghan coat in the 70’s, had a Schott leather jacket by the 80’s (story to that); sadly I can’t post any photo’s in response :slight_smile: Triumph colours look nice, I lusted after the Daytona in green & white in 1969 as a schoolboyr (poster on the wall of my bedroom) & the monoshocked Guzzi looks a little unusual. I kept my Commando in the lounge for a while when I rented a farmhouse here in Lincolnshire - really appreciated the warmth when spannering & yes kitchen was handy :slight_smile: One advantage of living alone is the ability to utilise oven, freezer & dishwasher without any petty differences of opinion :wink:

I reset the codes, charged battery & tried again, started successfully with just a press on the button, only one fault returned (DSB 007) so I’m hoping this is a voltage induced fault, or there will be more to do

Currently awaiting battery from M&S, but looks like a minimum 3 week delay,shop now closed, fingers x-ed the lockdown doesn’t need to be tightened/extended & hope people can stay clear of this virus.


aha, think I have the photo’s sorted - here’s a shot of the Sport last week in the Wolds…

…& for good measure one of the Commando aat the same location…

Cheers, Mike

I hate a thread without an ending,…

Searched many Guzzi forums! Cleared error codes, re-charged battery & ‘wiggled’ oil pressure sensor connection, re-connected battery, started bike & voila, no further error codes. So I suspect a combination of failing battery & possible the sensor switch/wiring issue.

Have now managed 200+ miles since the ‘fix’. the battery loses charge over a few days so it’s disconnected as soon as she’s garaged & charged immediately before use, will be replaced as & when we can move around again.


Well done, you are discovering the Guzzi’s “character” :smiley: